laravel/installer v2.0.1 requires ext-zip * -> the requested PHP extension zip is missing from your system

The error “laravel/installer v2.0.1 requires ext-zip * -> the requested PHP extension zip is missing from your system”. This error is something you can encounter when you install Laravel on a fresh Apache installation. Before you install the extension you should be aware of what version of PHP you have. If you have PHP 7, this is the command I used to install it.

sudo apt-get -y install php7.0-zip

If you need further help, check out the following links:

https://www.digitalocean.com/community/questions/php-7-0-ziparchive-library-is-missing-or-disabled

https://www.howtoinstall.co/en/ubuntu/xenial/php7.0-zip

Leave a Comment

Your email address will not be published. Required fields are marked *